This GitLab instance reached the end of its service life. It won't be possible to create new users or projects.

Please read the deprecation notice for more information concerning the deprecation timeline

Visit migration.git.tu-berlin.de to import your old projects to the new GitLab platform 📥

Commit a6d32189 by benkeks

Complete upgrade of Scala version

parent 2929d8bc
...@@ -36,7 +36,7 @@ lazy val shared = (project in file("shared")).settings( ...@@ -36,7 +36,7 @@ lazy val shared = (project in file("shared")).settings(
) )
lazy val jsClient = (project in file("js-client")).settings( lazy val jsClient = (project in file("js-client")).settings(
scalaVersion := "2.11.12", scalaVersion := "2.12.8",
name := "coupledsim-client", name := "coupledsim-client",
parallelExecution in ThisBuild := false, parallelExecution in ThisBuild := false,
scalacOptions ++= scalacOpts, scalacOptions ++= scalacOpts,
...@@ -59,7 +59,7 @@ lazy val jsClient = (project in file("js-client")).settings( ...@@ -59,7 +59,7 @@ lazy val jsClient = (project in file("js-client")).settings(
"org.webjars" % "bootstrap" % "3.3.7" / "bootstrap.min.js" "org.webjars" % "bootstrap" % "3.3.7" / "bootstrap.min.js"
), ),
unmanagedSourceDirectories in Compile += unmanagedSourceDirectories in Compile +=
baseDirectory.value / ".." / "shared" / "src" / "main" / "scala-2.11" baseDirectory.value / ".." / "shared" / "src" / "main" / "scala-2.12"
).aggregate(shared).dependsOn(shared).enablePlugins(ScalaJSPlugin, ScalaJSWeb) ).aggregate(shared).dependsOn(shared).enablePlugins(ScalaJSPlugin, ScalaJSWeb)
val flinkVersion = "1.7.0" val flinkVersion = "1.7.0"
......
package de.bbisping.coupledsim.tool package de.bbisping.coupledsim.tool
import scala.scalajs.js.JSApp import scala.scalajs.js.JSApp
import scala.scalajs.js.annotation.JSExport import scala.scalajs.js.annotation.JSExportTopLevel
import de.bbisping.coupledsim.tool.arch.Action import de.bbisping.coupledsim.tool.arch.Action
import de.bbisping.coupledsim.tool.arch.ActionDispatcher import de.bbisping.coupledsim.tool.arch.ActionDispatcher
import de.bbisping.coupledsim.tool.arch.Control import de.bbisping.coupledsim.tool.arch.Control
...@@ -12,7 +12,7 @@ import de.bbisping.coupledsim.tool.view.GraphRenderer ...@@ -12,7 +12,7 @@ import de.bbisping.coupledsim.tool.view.GraphRenderer
import de.bbisping.coupledsim.tool.view.SourceEditor import de.bbisping.coupledsim.tool.view.SourceEditor
import de.bbisping.coupledsim.tool.control.Pipeline import de.bbisping.coupledsim.tool.control.Pipeline
@JSExport @JSExportTopLevel("TransitionSystemFiddle")
object TransitionSystemFiddle extends JSApp with Control with ActionDispatcher { object TransitionSystemFiddle extends JSApp with Control with ActionDispatcher {
val source = new Source(this) val source = new Source(this)
......
...@@ -353,7 +353,7 @@ ...@@ -353,7 +353,7 @@
<script type="text/javascript" src="coupledsim-client-jsdeps.js"></script> <script type="text/javascript" src="coupledsim-client-jsdeps.js"></script>
<script type="text/javascript" src="js/cm_transitionsystem_mode.js"></script> <script type="text/javascript" src="js/cm_transitionsystem_mode.js"></script>
<script type="text/javascript" src="coupledsim-client.js"></script> <script type="text/javascript" src="coupledsim-client.js"></script>
<script type="text/javascript">de.bbisping.coupledsim.tool.TransitionSystemFiddle().main();</script> <script type="text/javascript">TransitionSystemFiddle.main();</script>
</body> </body>
</html> </html>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment